Cannot upgrade Plesk to the latest version: /usr/bin/sw-engine: error while loading shared libraries: libpq.so.4

Created:

2016-11-16 12:39:43 UTC

Modified:

2017-04-24 12:16:07 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot upgrade Plesk to the latest version: /usr/bin/sw-engine: error while loading shared libraries: libpq.so.4

Applicable to:

  • Plesk for Linux

Symptoms

Parallels Plesk Panel 9.5.4

CentOS release 5.5 x686

Upgrade to 11.5.30 version failed with error in /tmp/autoinstaller3.log :

Components validation detected at least one important issue:
Parallels Panel pre-upgrade check...
/usr/bin/sw-engine: error while loading shared libraries: libpq.so.4: cannot open shared object file: No such file or directory

Proceeding with installation or upgrade without resolving the issues
that were found can corrupt your data.

Cause

Failed package dependencies.

Resolution

To find out the required package run the command:

# yum provides /usr/lib/libpq.so.4 | grep -B2 base

Loading mirror speeds from cached hostfile
* addons: mirror.switch.ch
* base: mirror.switch.ch
--
postgresql-libs-8.1.23-6.el5_8.i386 : The shared libraries required for any
: PostgreSQL clients.
Repo : base

and install the required package:

yum install postgresql-libs-8.1.23-6.el5_8.i386

Now you can proceed the Plesk upgrade.

Have more questions? Submit a request
Please sign in to leave a comment.