Apache modules mod_security, mod_evasive20 or PHP extension Suhosin are used on the publishing server. How should I configure them to prevent any negative effects on Sitebuilder?

Created:

2016-11-16 12:39:15 UTC

Modified:

2017-08-16 18:32:36 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Apache modules mod_security, mod_evasive20 or PHP extension Suhosin are used on the publishing server. How should I configure them to prevent any negative effects on Sitebuilder?

Applicable to:

  • Plesk Sitebuilder for Linux

Symptoms

Apache modules mod_security ( mod_security2 ) and mod_evasive20 and PHP extension Suhosin on the publishing server may have various negative effects on the workings of Parallels Plesk Sitebuilder. Among them is the inability to manage modules or site publishing.

Resolution

mod_security ( mod_security2 ), mod_evasive20 , and Suhosin were not thoroughly tested with Plesk Sitebuilder. It is recommended to disable them on the publishing server.

To leave mod_seturity enabled you may try adding the directives below to the mod_security configuration.

<Directory /path/to/your-domain.com/public_html>
<Files server.php>
SecFilterScanPOST Off
</Files>
</Directory>

(where /path/to/your-domain.com/public_html is the location of the Apache virtual host the site is published to.)

Additional Information

Refer to this article for possible reasons for the error "Error! Operation has not been completed."

Have more questions? Submit a request
Please sign in to leave a comment.