[FIX] Older Plesk Versions - Security Update Custom Fixes for Linux, July 2012

Created:

2016-11-16 12:38:59 UTC

Modified:

2017-08-16 17:39:47 UTC

0

Was this article helpful?


Have more questions?

Submit a request

[FIX] Older Plesk Versions - Security Update Custom Fixes for Linux, July 2012

Applicable to:

  • Plesk 10.x for Linux
  • Plesk 9.x for Linux

Release Notes

This article provides fixes for the most critical vulnerabilities in older Parallels Plesk Panel versions, including 8.x, 9.0.x - 9.5.5, and 10.0.x - 10.4.4 on Linux.Even earlier versions, such as 7.x, 6.x, etc., must be upgraded to a later version that is not vulnerable.

NOTE: The mentioned fixes are available through the following Micro-Updates:

8.6.0 MU#15

9.5.4 MU#21

10.0.1 MU#14

10.1.1 MU#23

10.2.0 MU#17

10.3.1 MU#18

10.4.4 MU#39

Resolution

  1. Create a temporary directory:

    # mkdir plesk_remote_vulnerability_fix_deployer
  2. Go to the created directory:

    # cd plesk_remote_vulnerability_fix_deployer
  3. Download the attached file (md5sum: 7589fba44bd3d5b8c5b5c430a86d79f7) and decompress it:

    # wget https://support.plesk.com/hc/article_attachments/115004386069/plesk_remote_vulnerability_fix_deployer.tar.gz
    # tar -xzf plesk_remote_vulnerability_fix_deployer.tar.gz
  4. Run the following command from the created temporary directory:

    # /usr/local/psa/admin/bin/php plesk_remote_vulnerability_fix_deployer.php

NOTE: To simplify a mass deployment in the Parallels Virtuozzo Containers (PVC) for Linux environment, it is recommended that you utilize the plesk_remote_vulnerability_fix_mass_deployer script:

  1. Upload this archive to a separate folder on the Hardware Node: plesk_remote_vulnerability_fix_mass_deployer.tar.gz (md5sum: 2dd4f90ca8f591814dd7d7d2cf2e8477)

  2. Unpack the archive:

    # tar -xzf plesk_remote_vulnerability_fix_mass_deployer.tar.gz
  3. Run the contained shell script as root:

    # ./plesk_remote_vulnerability_fix_mass_deployer.sh

Expand specific

If you have 9.5.4 for Linux or 9.5.4/9.5.5 for Windows, both of which are managed by Parallels Expand, Parallels Plesk Panel 9.5.4 and Parallels Plesk Expand 2.3.2+ Compatibility Patch should be installed after applying the MUs or custom fixes.

Attachments:

Have more questions? Submit a request
Please sign in to leave a comment.