WordPress Installations error: "Decryption failed"

Created:

2016-11-16 13:26:03 UTC

Modified:

2017-08-08 13:28:44 UTC

0

Was this article helpful?


Have more questions?

Submit a request

WordPress Installations error: "Decryption failed"

Applicable to:

  • Plesk 12.0 for Linux

Symptoms

When clicking WordPress or WordPress Toolkit in Plesk, the following error appears:

    Error "Internal error: Decryption failed: error:00000001:lib(0):func(0):reason(1)", the wordpress did not list.

Cause

Database inconsistency. By some reason, encrypted WordPress admin's passwords in apsc database can not be decrypted.

Resolution

  1. Find encrypted passwords in apsc.aps_registry_object_setting table:

    mysql> select name,value,registry_object_id from apsc.aps_registry_object_setting where name='admin_password';

    +----------------+--------------------------------------+--------------------+
    | name | value | registry_object_id |
    +----------------+--------------------------------------+--------------------+
    | admin_password | $AES-128-==$lVykWIz7QdAxdAY+vp2q4g== | 40 |
    +----------------+--------------------------------------+--------------------+
  2. Use registry_object_id value to update record:

    mysql>  update apsc.aps_registry_object_setting set value='password' where registry_object_id=40 and name='admin_password';
  3. Change password using Plesk .

Have more questions? Submit a request
Please sign in to leave a comment.