Upgrade to Plesk 12 fails: Unable to resolve components request mode changeset due to inter-component dependencies.

Created:

2016-11-16 13:25:57 UTC

Modified:

2017-04-24 11:35:49 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Upgrade to Plesk 12 fails: Unable to resolve components request mode changeset due to inter-component dependencies.

Applicable to:

  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

Plesk upgrade from 11.5 to 12 failed with error:

ERROR: Unable to resolve components request mode changeset due to inter-component dependencies. You possibly need to remove some of the conflicting components. Check '/var/log/plesk/install/autoinstaller3.log' for more details.

The following warning can be found in '/var/log/plesk/install/autoinstaller3.log' file:

Warning: found inter-component dependencies conflict between 'msmtp' (will be installed: 1, request = REQ_INSTALL) and 'courier' (will be installed: 1, request = REQ_INSTALL) while trying to resolve REQ_INSTALL of component 'awstats' and 12 more change(s)

Cause

External SMTP Server is used. Mail server packages were not fully removed.
This is a software issue with internal ID PPPM-2252

Resolution

Remove psa-courier-authlib and psa-courier-imap packages:

# yum remove psa-courier-authlib psa-courier-imap
Have more questions? Submit a request
Please sign in to leave a comment.