Unable to upgrade Plesk: Yum utility Segmentation fault

Created:

2016-11-16 13:25:54 UTC

Modified:

2017-08-16 16:26:30 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to upgrade Plesk: Yum utility Segmentation fault

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux
  • Plesk 10.x for Linux

Symptoms

Plesk upgrade failing every time on the package instalation steps with following error:

ERROR: The Yum utility failed to install the required packages.

Manual run of the "yum" utility fails with "Segmentation fault" error:

#  yum check-update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: centos.serverspace.co.uk
* extras: centos.serverspace.co.uk
* updates: mirrors.coreix.net
Segmentation fault

Cause

Common reason for such yum failures is that zlib was installed from source code. Or there are several zlib instalaltions on the server. See also Centos #4355 .

Resolution

Make sure that libz libraries are loaded correctly. Check if you have libz files under /usr/local/lib/ directory. If there is, try to move them somewhere and check yum command again.

On test Plesk 12 server (Centos 6.5 x64), files are located correctly under this directory:

    # locate libz.so
/lib/libz.so.1
/lib/libz.so.1.2.3
/lib64/libz.so.1
/lib64/libz.so.1.2.3
/var/www/vhosts/chroot/lib64/libz.so.1


# ls -la /lib/libz.so.1 /lib/libz.so.1.2.3 /lib64/libz.so.1 /lib64/libz.so.1.2.3
lrwxrwxrwx 1 root root 13 Dec 11 2013 /lib64/libz.so.1 -> libz.so.1.2.3
-rwxr-xr-x 1 root root 88600 Feb 22 2013 /lib64/libz.so.1.2.3
lrwxrwxrwx 1 root root 13 Dec 11 2013 /lib/libz.so.1 -> libz.so.1.2.3
-rwxr-xr-x 1 root root 75384 Feb 22 2013 /lib/libz.so.1.2.3
Have more questions? Submit a request
Please sign in to leave a comment.