Plesk upgrade fails: "php53-common conflicts with php-common"

Refers to:

  • Plesk 10.4 for Linux
  • Plesk for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:25:44 UTC

Modified:

2016-12-21 20:41:32 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade fails: "php53-common conflicts with php-common"

Notification

For Plesk 11.5 and later, please, contact Plesk Technical Support regarding this issue. Atomic and Remi repositories are supported for those Plesk versions (see the article #213917765 for more details).

Symptoms

A Plesk upgrade fails with the following error:

php53-common-5.3.3-13.el5_9.1.i386 from updates has depsolving problems
--> php53-common conflicts with php-common
Attempt to remove 'php53-common' to resolve conflict has succeeded

Cause

The Atomic repository was enabled on the server:

~# yum provides php-common
php-common-5.4.18-24.el5.art.i386 : Common files for PHP
Repo : atomic
Matched from:
..

Plesk 11.0 is installed with the php53-common package. The format is:

php53(version)-common

However, the php-common package in the Atomic repository has a different name format:

php-common(package name)-5.4(package version)

Resolution

Re-run the upgrade with the Atomic repository disabled. Specify enabled = 0 in /etc/yum.repos.d/atomic.repo .

Have more questions? Submit a request
Please sign in to leave a comment.