504 Gateway Timeout is shown while accessing Backup Manager with configured FTP storage: Unable to download remote file

Created:

2016-11-16 13:25:32 UTC

Modified:

2017-08-16 13:04:19 UTC

3

Was this article helpful?


Have more questions?

Submit a request

504 Gateway Timeout is shown while accessing Backup Manager with configured FTP storage: Unable to download remote file

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux

Symptoms

  • When trying to open Backup Manager , the page loads a long time and then fails with 504 Gateway Time Out error message.

  • The following message could be found in /var/log/sw-cp-server/error_log file:

    [error] 2586#0: *107 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 203.0.113.2, server: , request: "GET /admin/backup/list HTTP/1.1", upstream: "fastcgi://unix:/var/run/sw-engine.sock", host: "example.com:8443", referrer: "https://example.com:8443/admin/server/tools?context=tools"
    
  • With debug mode enabled the error can be observed in /var/log/plesk/panel.log :

    ERR [panel] Get dump 'backup_info_1604230701.xml': Transport error: Unable to download remote file 'ftp://ftp.example.com//BackUpFolder/backup_info_1604230701.xml': Curl error: Remote file not found. Server response code: 550
    

    ftp://ftp.example.com/BackUpFolder/backup_info_1604230701.xml file does not exist on the FTP server.

  • If backups are located on a local file system, errors like the following are logged into /var/log/plesk/panel.log or into /var/log/plesk/PMM/pmmcli.log :

    ERR [panel] Get dump 'backup_info_1605090205.xml': Transport error: File 'backup_info_1605090205.xml' not found
    

    backup_info_1605090205.xml file does not exist on the server.

Cause

A corrupted tasks database.

Resolution

Remove or rename tasks.db file:

# mv /usr/local/psa/PMM/tasks/tasks.db{,.back}
Have more questions? Submit a request
Please sign in to leave a comment.