Could not activate Outbound Antispam: "Error: Invalid License key"

Refers to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Created:

2016-11-16 13:24:43 UTC

Modified:

2016-12-21 20:39:29 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Could not activate Outbound Antispam: "Error: Invalid License key"

Symptoms

  1. Parallels Premium Outbound Antispam could not be activated, the following error is shown:

    Error: Invalid License key
  2. However on Tools & Settings > Outgoing Spam Filter > Server Configuration tab license key is shown as valid, not "xxxxxxxxxxxxxxx"

  3. Also when you try to add email into white list the following error is shown:

    can't open /etc/ctasd/senderid_white file

Cause

The most likely cause is that the Parallels Plesk Panel service cannot execute backend utility or executed utility is unable to change some file because of lack of permissions.

Resolution

Make sure that the following files have the proper permissions and owners:

    # ls -al $PRODUCT_ROOT_D/admin/sbin/*wrapper
---s--x--- 1 root psaadm 13120 Jun 13 21:51 ./admin/sbin/mod_wrapper
---s--x--- 1 root psaadm 13632 Jun 13 21:51 ./admin/sbin/wrapper

If you see different permissions or owners, use following commands to correct them:

    # cd $PRODUCT_ROOT_D
# chown root:psaadm ./admin/bin/*wrapper
# chmod 4110 ./admin/bin/*wrapper
Have more questions? Submit a request
Please sign in to leave a comment.