Unable to find ModSecurity or Fail2Ban management tool in Plesk GUI.

Created:

2016-11-16 13:24:28 UTC

Modified:

2017-04-24 11:17:31 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Unable to find ModSecurity or Fail2Ban management tool in Plesk GUI.

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

NOTE: Fail2Ban is not available on Windows platform.

Symptoms

Unable to find ModSecurity or Fail2Ban management tool in Plesk GUI.

Cause

Security Core (ModSecurity and Fail2Ban) may absent because license key has no corresponding property or it was just not installed/enabled on server.

Resolution

To check whether the license key supports it, go to
Server Management > Tools & Settings > License Management , and see if there is the line "Security core (ModSecurity and Fail2Ban)".

Fail2Ban component can be installed in
Tools & Settings > Updates and Upgrades > Add or Remove Components > Fail2Ban authentication failure monitor

ModSecurity component can be installed in
Tools & Settings > Updates and Upgrades > Add or Remove Components > Web hosting features > ModSecurity Web Application Firewall for Apache

ModSecurity component should be enabled in /usr/local/psa/admin/conf/panel.ini file:

    [modSecurity]
enabled = true
Have more questions? Submit a request
Please sign in to leave a comment.