Plesk for Linux
DoNotDelete:docref
kb: technical
ABT: Group A
Applicable to:
- Plesk for Linux
Symptoms
Plesk update fails:
PLESK_ERROR: Some database entries related to Panel IP addresses are corrupted. Please see kb.plesk.com/en/113826 for the solution.
Cause
Plesk database inconsistency. One or more IP address collections are assigned to a non-existent IP address.
Resolution
- Connect to Plesk server using SSH.
- Back up Plesk database.
- Access Plesk database:
# plesk db
- Find IP address collections with non-existent IP addresses assigned:
MYSQL_LIN: select * from IpAddressesCollections where ipAddressId not in (select id from IP_Addresses);
+----------------+-------------+
| ipCollectionId | ipAddressId |
+----------------+-------------+
| 245 | 0 |
+----------------+-------------+ - Delete orphaned records (copy the corresponding IDs found in the previous step):
MYSQL_LIN: delete from IpAddressesCollections where ipCollectionId=245 and ipAddressId=0;
Note: If there are more than 1 ID in step 4, repeat step 5 for each of them.
Comments
8 comments
Plesk 17.0.17 #54
CentOS Linux 7.5.1804 (Core)
I get the warning "Some database entries related to Panel IP addresses are corrupted." and have run the DB code which shows no entries for ipAddressId=0, so there are no orphaned records.
When I run
select * from IpAddressesCollections
there are 16 rows of data where ipAddressId is either 1 or 2.
Hello @Trevor,
in this case, ipAddressId is not meant to be 0, have used the query (select * from IpAddressesCollections where ipAddressId not in (select id from IP_Addresses);) or modified it somehow?
Thank you @Ivan
This is what I get when running the query command. This is the first time I've ever been into SSH to run any plesk db commands so I don't know how to modify anything. I spend most of my time on Windows servers so the SSH command line is alien to me.
Hi @Trevor, I am glad to know that my advice helped.
Hi @Ivan , I'm still not sure how your advice of "ipAddressId is not meant to be 0" helps.
Plesk update warns of "Some database entries related to Panel IP addresses are corrupted" and yet upon investigation it appears I have no records where ipAddressId=0. Does this mean I have no corrupted IP addresses? If so, why is Plesk telling me I have?
Hello @Trevor,
Let me explain: the corrupted IP does not necessary has ID 0, it may have other value.
In your case, this values is 1.
So, to resolve the issue, you should backup Plesk database (there is a link in this article) and delete rows with such ID, for example:
delete from IpAddressesCollections where ipCollectionId=1 and ipAddressId=1;
delete from IpAddressesCollections where ipCollectionId=3 and ipAddressId=1;
...
In case further assistance with issue resolution is required, consider submitting a support request.
HI!
I am getting the same error! Altough I have 4 diferent records! Can I delete them all? If not witch one should I delete? Thank you in advance!
ipCollectionId IpAddressId
3 1
5 1
4 2
7 2
Amaro Amaral Hi! Please open a support ticket with us https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-. We need to determine which IP is being used at the moment.
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