Plesk Mobile: Unknown SSL protocol error in connection to 127.0.0.1:8443

Created:

2016-11-16 13:23:44 UTC

Modified:

2017-08-16 17:15:41 UTC

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Plesk Mobile: Unknown SSL protocol error in connection to 127.0.0.1:8443

Applicable to:

  • Plesk 12.5 for Windows

Symptoms

  • The following error may pop up on some of the screens of Plesk Mobile application:
    Unknown SSL protocol error in connection to 127.0.0.1:8443

For instance, one might observe it on the Info screen.

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  • Other screens might have:

    An internal error has occurred. Please contact our support representatives.
  • Settings screen buttons are inactive

  • Issues with establishing connection in the first place:

    SSL handshake aborted: ssl=0xaa0b6640: I/0 error during sytem call, Connection reset by peer

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  • Plesk can only be accessed via https://FQDN:8443

Cause

  • Customised IP bindings for pleskcontrolpanel website in IIS manager.
  • Require Server Name Indication checkbox is marked in IIS > Sites > pleskcontrolpanel > Bindings > Host name :

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Because of the aforementioned reasons Plesk Mobile app cannot establish an SSL handshake.

Resolution

pleskcontrolpanel is a separate instance that does not require SNI .

Default pleskcontrolpanel bindings should be set as follows:

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Once those are set, restart pleskcontrolpanel site in Manage Website pane.

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