Unable to access Plesk: symbol lookup error: /usr/bin/sw-engine: undefined symbol

Created:

2016-11-16 13:23:26 UTC

Modified:

2017-08-16 16:39:35 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to access Plesk: symbol lookup error: /usr/bin/sw-engine: undefined symbol

Applicable to:

  • Plesk for Linux

Symptoms

  1. It is not possible to connect to the Plesk, with 500 Internal Server error.

  2. The following error appears when attempting to run any Plesk CLI:

    /usr/bin/sw-engine: symbol lookup error: /usr/bin/sw-engine: undefined symbol: _ZNK3APS4Meta10ScriptInfo13isPriveledgedEv

Cause

The upgrade was not completed successfully. The libaps and sw-engine packages are from different Plesk versions.

Resolution

  1. Check the installed libaps package version:

    #rpm -qa | grep libaps
    libaps-1.0.4-768202.12060417

    Find below the supported package and Plesk versions:

    Plesk 10.4.4  - libaps-1.0.2
    Plesk 11.0.9 - libaps-1.0.4
    Plesk 11.5.30 - libaps-1.0.6
    Plesk 12.0.18 - libaps-1.0.7
  2. Check the sw-engine package version:

    #rpm -qa | grep sw-engine
    sw-engine-2.13.11-centos5.201407011509

    Find below the supported package and Plesk versions:

    Plesk 10.4.4  - sw-engine-2.3
    Plesk 11.0.9 - sw-engine-2.5.1
    Plesk 11.5.30 - sw-engine-2.9.8
    Plesk 12.0.18 - sw-engine-2.13.11
  3. If the libaps package version is not correct, uninstall it. The example below is provided for Plesk 10.4.4:

    # rpm -e libaps-1.0.4-768202.12060417 --nodeps
  4. Install the correct version based on your Plesk version, server OS, and architecture. The example below is provided for CentOS 5 x86_64 running Plesk 10.4.4:

    #  wget http://autoinstall.plesk.com/PSA_10.4.4/dist-rpm-CentOS-5-x86_64/contrib/libaps-1.0.2-669424.11082615.x86_64.rpm
    # rpm -ihv libaps-1.0.2-669424.11082615.x86_64.rpm
  5. Run /usr/local/psa/admin/sbin/autoinstaller .

  6. If the autoinstaller shows that all components are up-to-date, make sure sw-engine and libaps are for the same Plesk version. Update the first or second package as necessary.

Have more questions? Submit a request
Please sign in to leave a comment.