IP addresses management error: "Incorrect format of RTM_GETADDR request response"

Refers to:

  • Plesk 11.5 for Linux

Created:

2016-11-16 13:23:22 UTC

Modified:

2016-12-21 20:36:24 UTC

0

Was this article helpful?


Have more questions?

Submit a request

IP addresses management error: "Incorrect format of RTM_GETADDR request response"

Symptoms

IP address management fails with the error:

  1. The issue occurs when I try to add and IP address in Plesk Panel: Tools & Settings > IP Addresses . The error below is shown in the GUI:

    Incorrect format of RTM_GETADDR request response
  2. The same issue occurs in Parallels Plesk Automation when I try to create subscription, "Add the IP address 10.10.0.56" task fails with error:

    Incorrect format of RTM_GETADDR request response

Cause

Plesk unable to manage more than 200 IP addresses. The issue is considered to be a software issue, internal request ID is PPPM-1274 .

Resolution

The issue will be fixed in future product updates, please monitor our RSS channel to get information about updates.

Workaround

The hotfix is available. There are files for different OS'es in archive attached. Extract the proper one for your operational system and replace the '/usr/local/psa/admin/sbin/ifmng' with it having assigned appropriate permissions to the file afterwards:

# mv /usr/local/psa/admin/sbin/ifmng /usr/local/psa/admin/sbin/ifmng.back
# mv ifmng-bcos6x64 /usr/local/psa/admin/sbin/ifmng
# chmod +x /usr/local/psa/admin/sbin/ifmng

NOTE: The actions above must be performed on the SERVICE NODE where the subscription is about to be hosted.

Have more questions? Submit a request
Please sign in to leave a comment.