Applicable to:
- Plesk for Linux
Symptoms
-
Website is showing the following error:
CONFIG_TEXT: 503 Service Temporarily Unavailable
-
The following errors are shown in
/var/log/plesk/panel.log
log file:PLESK_INFO: [proxy:error] [pid 12966] AH00959: ap_proxy_connect_backend disabling worker for (127.0.0.1) for 60s
[proxy_fcgi:error] [pid 12966] [client 203.0.113.2:53377] AH01079: failed to make connection to backend: 127.0.0.1, referer: https://example.com/ - The website is using PHP-FPM handler at Domains > example.com > PHP Settings
-
The following errors can be found in the website
error_log
file at/var/www/vhosts/example.com/logs/error_log
:PLESK_INFO: [proxy:error] [pid 3838:tid 140126940247808] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/www/vhosts/system/example.com/php-fpm.sock (*) failed
[proxy_fcgi:error] [pid 3838:tid 140126940247808] [client 203.0.113.2:56904] AH01079: failed to make connection to backend: httpd-UDS
Cause
PHP-FPM service is stopped.
Resolution
Warning: To apply these steps is required access to the server as Plesk administrator. If you don't have admin access, please contact your service provider.
Click on a section to expand
- Check what version of PHP is used by domain at Domains > example.com > PHP Settings
-
Go to Tools & Settings > Services Management
-
Start the PHP-FPM service with the required version. For example the Plesk PHP-FPM 7.3 service:
-
Connect to the server via SSH
-
Get the PHP-FPM version assigned to the domain:
# plesk db "SELECT d.name,h.php_handler_id FROM domains d JOIN hosting h on h.dom_id=d.id WHERE d.name='example.com'"
+-------------+----------------+
| name | php_handler_id |
+-------------+----------------+
| example.com | plesk-php73-fpm |
+-------------+----------------+ -
Start the PHP-FPM service with the required version. For example the Plesk PHP-FPM 7.3 service:
# service plesk-php73-fpm restart
-
Connect to the server via SSH
-
Restart all the enabled PHP-FPM services:
# for PHP in `systemctl list-unit-files | grep enabled | grep php.*fpm | awk '{print $1}'`; do echo -e "PHP-FPM service:\t$PHP"; echo -e "Status:\t$(systemctl is-active $PHP)"; echo -e "Restarting..."; systemctl restart $PHP; echo -e "Status:\t$(systemctl is-active $PHP)\n"; done
Additional Information
Domain does not work on PHP-FPM on Plesk: 503 service unavailable
Comments
8 comments
Seems that this service is not started at boot. You should start it manually from Tools & Settings > Services Management.
When I experienced crash of this service today, I restarted the whole server but the service wasn't start at boot.
In the the log below, for PHP-FPM 5.6 handler, you can see that service never tried to start at boot. Reboot was done after 08:46, time of last status log entry for such service. Starting service manually worked without any issue. The same applies to PHP-FPM 7.1 handler.
This server is Ubuntu 16.04.3 LTS (upgraded from 14.04 following the KB procedure) with Plesk 17.5.3 Update #28.
@Marco
As I can see, the service is enabled, and the only explanation why it won't start at the boot is a failed dependency. plesk-php56-fpm depend on network and syslog:
Try to check if syslog works correctly:
@Denis dependencies are ok, otherwise launching the service manually will fail too. As I said, starting the service manually worked.
Btw I checked the syslog:
@Marco
Are there some related errors in '/var/log/plesk-php56-fpm/error.log' and '/var/log/plesk-php71-fpm/error.log' files?
If not, and the issue can be reproduced, I suggest raising a support ticket regarding this behavior.
Encountering this error when trying to access .php files, any ideas?
@Florian
Hello!
Such behavior may be caused by PHP-FPM service. Try to apply this article.
In case the issue will persist, consider contacting Plesk Support.
@Denis There isn’t any error in such log files, because the service is not called at all. Seems this happens after performing Ubuntu 14>16 upgrade, following KB instructions, that broke some things. Maybe the installer doesn’t reconfigure some services to start at boot. This happened with other services and it was classified as bug.
@Marco Marsala
Hi!
As @Denis Bykov mentioned, we suggest raising a support ticket regarding this behavior.
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