Plesk packages has been removed through YUM

Created:

2016-11-16 13:22:39 UTC

Modified:

2017-04-24 11:37:35 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk packages has been removed through YUM

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

RedHat-based OS is used as the server OS.

Plesk package has been removed by YUM.

    yum remove psa-libxml-proxy
Loaded plugins: fastestmirror
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package psa-libxml-proxy.x86_64 0:2.7.8-13032215 will be erased
--> Processing Dependency: psa-libxml-proxy for package: plesk-core-11.5.30-cos6.build115130819.13.x86_64
--> Running transaction check
---> Package plesk-core.x86_64 0:11.5.30-cos6.build115130819.13 will be erased
--> Processing Dependency: plesk-core >= 11.5.30 for package: plesk-management-node-11.5.30-cos6.build115130819.13.x86_64
--> Processing Dependency: plesk-core >= 11.5.30 for package: plesk-l10n-11.5.30-cos6.build115130819.13.noarch
--> Processing Dependency: plesk-core >= 10.3.0 for package: pp-sitebuilder-11.5.10-42107.13120413.noarch
--> Processing Dependency: plesk-core >= 11.5.30 for package: psa-updates-11.5.30-cos6.build115131204.15.noarch
--> Running transaction check
---> Package plesk-l10n.noarch 0:11.5.30-cos6.build115130819.13 will be erased
---> Package plesk-management-node.x86_64 0:11.5.30-cos6.build115130819.13 will be erased
---> Package pp-sitebuilder.noarch 0:11.5.10-42107.13120413 will be erased
---> Package psa-updates.noarch 0:11.5.30-cos6.build115131204.15 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================================================

Package Arch Version Repository Size

============================================================================================================================================================================================================

Removing:
psa-libxml-proxy x86_64 2.7.8-13032215 installed 1.1 M
Removing for dependencies:
plesk-core x86_64 11.5.30-cos6.build115130819.13 installed 41 M
plesk-l10n noarch 11.5.30-cos6.build115130819.13 installed 20 M
plesk-management-node x86_64 11.5.30-cos6.build115130819.13 installed 0.0
pp-sitebuilder noarch 11.5.10-42107.13120413 installed 213 M
psa-updates noarch 11.5.30-cos6.build115131204.15 installed 2.0 k

Transaction Summary

============================================================================================================================================================================================================

Remove 6 Package(s)

Installed size: 275 M
Is this ok [y/N]:

This action has triggered removing Plesk-core package as a depended one.

Cause

Incorrect removing of the Plesk components.

Resolution

  1. Install Plesk with autoinstaller:

    /usr/local/psa/admin/bin/autoinstaller

  2. Restore Plesk DBs from backups

    zcat /var/lib/psa/dumps/mysql. .dump.gz | mysql -uadmin -p cat /etc/psa/.psa.shadow psazcat /var/lib/psa/dumps/mysql. .dump.gz | mysql -uadmin -p cat /etc/psa/.psa.shadow apsc

Have more questions? Submit a request
Please sign in to leave a comment.