Failed to initiate callback from source server during migration

Created:

2016-11-16 13:22:38 UTC

Modified:

2017-04-24 11:37:36 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Failed to initiate callback from source server during migration

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Symptoms

Migration failed with error:

Erro: Error on call plesk-migrator callback "C:\\Program Files (x86)\\Parallels\\Plesk\\/var/modules/panel-migrator/sessions/20151107003432/config.ini" --command="generate-migration-list --skip-services-checks"

CODE: 1

STDOUT:
[INFO] Initialize migrator
[INFO] Load configuration
[INFO] Source Plesk 'source' host: 1.1.1.1
[INFO] START: Initiate callback from source server
[INFO] Deploy and start panel migrator transfer agent at '1.1.1.1'
[ERROR] Failed to initiate callback from source server
Cause: Panel Migrator failed to install Transfer Agent to '1.1.1.1' server.
Transfer Agent is required for communication between current server and '1.1.1.1' server

Cause

Transfer Agent is required for communication between target server and source server. Connectivity between servers is broken.

Troubleshooting

  • First, check that Windows Administrator's credentials in %plesk_dir%\\var\\modules\\panel-migrator\\sessions\\20151107003432\\config.ini are correct for the server

  • If they are correct, it is very likely that Samba is disabled on the remote server, so automatic installation of agent is not possible. To install it manually:

  • On the 1.1.1.1 server create directory C:\panel_migrator\panel-transfer-agent

  • Upload the file %plesk_dir%\\var\\modules\\panel-migrator\ hirdparties\\panel-migrator-tran sfer-agent-installer.exe from the target server 2.2.2.2 to source C:\panel_migrator\panel-transfer-agent .

  • Run panel-migrator-transfer-agent-installer.exe on the 1.1.1.1 server.

  • Open C:\panel_migrator\panel-transfer-agent directory in Windows Explorer.

  • Run 'start.bat' script there.

Also, check that there are no firewall rules blocking connections to 10155 port on 1.1.1.1 from that server.

NOTE: Additionally for troubleshooting, refer to debug.log and info.log located in C:\panel_migrator\panel-transfer-agent on destination and source servers.

Have more questions? Submit a request
Please sign in to leave a comment.