Unable to upgrade Plesk: Error getting repository data for PPB_12_0_18-dist, repository not found

Refers to:

  • Plesk 12.0 for Linux

Created:

2016-11-16 13:22:29 UTC

Modified:

2016-12-21 20:34:32 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to upgrade Plesk: Error getting repository data for PPB_12_0_18-dist, repository not found

Symptoms

Plesk upgrade failed with error:

RepoError: Error getting repository data for PPB_12_0_18-dist, repository not found

ERROR: The Yum utility failed to install the required packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

Cause

Incorrect settings in /etc/yum.conf

Resolution

Disable all additional settings in /etc/yum.conf .

For example, it should look like this on CentOS 5 :

[main]
cachedir=/var/cache/yum
keepcache=0
debuglevel=2
logfile=/var/log/yum.log
distroverpkg=redhat-release
tolerant=1
exactarch=1
obsoletes=1
gpgcheck=1
plugins=1
bugtracker_url=http://bugs.centos.org/yum5bug

# Note: yum-RHN-plugin doesn't honor this.
metadata_expire=1h

installonly_limit = 5

# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d
Have more questions? Submit a request
Please sign in to leave a comment.