pmmcli '--get-config-parameters' Segmentation fault

Created:

2016-11-16 13:22:04 UTC

Modified:

2017-04-24 11:37:54 UTC

0

Was this article helpful?


Have more questions?

Submit a request

pmmcli '--get-config-parameters' Segmentation fault

Applicable to:

  • Plesk 12.0 for Linux

Symptoms

Cannot delete domain from Plesk.

The following command causes Segmentation fault:

/usr/local/psa/admin/bin/pmmcli '--get-config-parameters'
Segmentation fault (core dumped)

The library /lib/libz.so.1 and /lib/libz.so linked to libz.so.1.2.8

#ll /lib/libz.so.1
lrwxrwxrwx 1 root root 13 Jul 25 00:00 /lib/libz.so.1 -> libz.so.1.2.8

In /var/log/message the following error can be found:

kernel: xmllint[47946]: segfault at 7f7800000000 ip 00007f783a252220 sp 00007fffb02d89c8 error 4 in libc-2.12.so[7f783a129000+18a000]

Cause

Custom ' libz.so.1.2.3 ' library is installed on the server.
libz.so.1.2.8 is incomparable with libxml2-2.7.6

Resolution

Remove custom libz.so and restore links to the correct version.

[root@ ~]# rm /lib/libz.so
rm: remove symbolic link `/lib/libz.so'? y
[root@ ~]# rm /lib/libz.so.1
rm: remove symbolic link `/lib/libz.so.1'? y
[root@ ~]# cd /lib
[root@ lib]# ln -s libz.so.1.2.3 /lib/libz.so
[root@ lib]# ln -s libz.so.1.2.3 /lib/libz.so.1
Have more questions? Submit a request
Please sign in to leave a comment.