'Apache Module' and 'CGI application' not available

Created:

2016-11-16 13:21:41 UTC

Modified:

2017-08-08 13:39:38 UTC

0

Was this article helpful?


Have more questions?

Submit a request

'Apache Module' and 'CGI application' not available

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Symptoms

In Websites & Domains > [Domain] > Hosting Settingsthe item "PHP support Run PHP as" only 'FastCGI application' option is shown. There is no 'Apache Module' and 'CGI application' items in the drop down.

Checked KB #114601 but it was not that.

[root@myserver ~]# /usr/local/psa/bin/domain --update test.co.jp -php_handler_id module
Wrong value of php_handler_id, it can take only fastcgi, plesk-php53-fastcgi

The goal is to have 'Apache Module' and 'CGI application' items shown and find out what was wrong.

The errors like the following in panel.log:

[2015-04-28 19:45:36] ERR [panel] Unable to apply plan changes to domain domain.tld. Error: The plan was not applied: Common PHP settings management

Cause

The reason why there were no 'Apache Module' and 'CGI application' items in the drop down is that "Setup of potentially insecure web scripting options that override provider's policy" option was not enabled in "Tools & Settings > Custom View Settings > Hosting Tools".

Resolution

Enable "Setup of potentially insecure web scripting options that override provider's policy" option in "Tools & Settings > Custom View Settings > Hosting Tools".

Have more questions? Submit a request
Please sign in to leave a comment.