Microupdate installation error: "The MD5 checksum of the php.tmp file does not match the value specified in the configuration file"

Created:

2016-11-16 13:21:04 UTC

Modified:

2017-08-16 16:13:14 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Microupdate installation error: "The MD5 checksum of the php.tmp file does not match the value specified in the configuration file"

Applicable to:

  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

The local Plesk mirror is used:

# cat /root/.autoinstallerrc
SOURCE=http://mirror.mirror.tld/pp12

The following error appears in /tmp/autinstaller3.log during installation of microupdate:

    Error: error during prepare patch plesk-12.0.18~patch38
The MD5 checksum of the /root/parallels/PSA_12.0.18/microupdates/MU38/common/admin/plib/AdminPanel/Form/Final/EditSubscription.php.tmp file does not match the value specified in the configuration file.
Not all packages were installed.
Please resolve this issue and try installing the packages again.
If you cannot resolve the issue on your own, contact product technical support for assistance.

Cause

Script handlers are not disabled in /etc/httpd/conf.d/ on mirror server.

Resolution

Make sure that mirror meets of requirements in the article about Plesk Mirror Setup :

  1. Virtual host used for mirroring should have all script handlers (php, pl, cgi, py, fcgi etc) disabled.

  2. Virtual host or directory used for mirroring should have option +FollowSymLinks set.

  3. Unless other sources are specified, rsync://rsync.autoinstall.plesk.com/autoinstall and rsync://autoinstall-win.pp.parallels.com/autoinstall for Plesk Windows must be accessible from the machine where the script is being run and from the destination machine.

  4. PHP must be compiled with support of the below extensions on the machine where the script is being run (see http://www.php.net/manual/en/ssh2.installation.php): ssh2_connect simplexml XML DOM

Have more questions? Submit a request
Please sign in to leave a comment.