Unable to login to CloudFlare: invalid email, error code 1010

Created:

2016-11-16 13:20:55 UTC

Modified:

2017-08-08 13:39:24 UTC

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Unable to login to CloudFlare: invalid email, error code 1010

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.5 for Windows

Symptoms

Unable to login to CloudFlare account by clicking on the following option:

Otherwise, create an account and activate this module using <plesk_admin_email>.

It results in:

Invalid email

The following error is shown in panel.log on Linux or php_error.log on Windows:

[SERVERSHIELD] CloudFlare API: (400) {"success":false,"errors":[{"code":1010,"message":"Invalid email"}],"messages":[],"result":null}

Cause

Temporary issue on Cloudflare side

Resolution

Contact Plesk support so that we report the issue to CloudFlare. When it is fixed, an account will be activated by clicking on:

Otherwise, create an account and activate this module using <plesk_admin_email>.
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