How to perform dist-upgrade procedure on Linux server with Plesk?

Follow

Comments

42 comments

  • Avatar
    Jan Bludau

    How to make a dist-upgrade from Plesk 17.8.11 i can't find the dist-upgrade helper script on the mentationed position.

    0
    Comment actions Permalink
  • Avatar
    Nikita Nikushkin

    Hi @Jan Bludau,

    Could please provide us with the OS?

    Thank you!

    0
    Comment actions Permalink
  • Avatar
    Oliver Mueller

    Still no migration path for Ubuntu 16.04 to 18.04? It is almost a year ago, that Ubuntu 18.04 is supported by Plesk (fresh installation). Is there any ETA on this topic? A migration to another server with fresh installed plesk is no option for us. We really need this upgrade/migration.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello @Oliver,

    Thank you for the feedback.

    I will need some time to clarify if there's the exact ETA.

    Me or my colleague will let you know when receive the information.

    0
    Comment actions Permalink
  • Avatar
    Oliver Mueller

    Still no ETA? Even an approximation would help.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello @Oliver,

    I will clarify the plans for this functionality and will update write to them here, after I'll get any news.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello @Oliver,

    According to the information I got, the Development team still has plans to implement this functionality.

    The ETA will be available later. 

    News will be added to this article.

    0
    Comment actions Permalink
  • Avatar
    Elisabeth Kahnert

    Upgrade from Ubuntu 16 to Ubuntu 18 is needed

    0
    Comment actions Permalink
  • Avatar
    Julian Bonpland Mignaquy

    @Elisabeth,

    Currently, Plesk does not support dist-upgrade from Ubuntu 16.04 to Ubuntu 18.04 yet. Dist-upgrade support from Ubuntu 16.04 to Ubuntu 18.04 to Plesk, will be added in a future product update.

    -2
    Comment actions Permalink
  • Avatar
    Elisabeth Kahnert

    @Julian Bonpland Mignaquy

    Yes, and this text is more than 1 year old.

    0
    Comment actions Permalink
  • Avatar
    Sandonanet s.n.c.

    Hi, i have Ubuntu 14.04.6 LTS with Plesk Onyx Version 17.8.11 and i want upgrade my system to ubuntu 16.04 LTS.

    I have performed the procedure you indicated and run the script /opt/psa/bin/distupgrade.helper.ubt14-ubt16.x64.sh

    The procedure is performed correctly except the update of mysql 5.5 to 5.7 which remains an error.

    I have restored the initial backup of the machine and retried the procedure several times but the error persists.

    I also tried to manually update mysql from version 5.5 to 5.6 but the procedures I found on the net do not work.

    Can anyone help me? Thank you

     

     

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello @Sandonanet s.n.c.,

    Try steps for Debian from this article: https://support.plesk.com/hc/en-us/articles/213403429-How-to-upgrade-MySQL-5-5-to-5-6-5-7-or-MariaDB-5-5-to-10-0-10-1-10-2-on-Linux-

    In case this wouldn't help, I can suggest preparing a new server with the required OS, install fresh Plesk and migrate domains: https://support.plesk.com/hc/en-us/articles/213912645-Plesk-Migration-and-Transfer-Guide

    These operations may also be done on a paid basis by Plesk Professional services team: https://www.plesk.com/professional-services/

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request