Unable to update to Joomla 3.4.8-89: Failed opening required \\libraries/import.legacy.php

Created:

2016-11-16 13:20:08 UTC

Modified:

2017-08-16 16:59:57 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to update to Joomla 3.4.8-89: Failed opening required \\libraries/import.legacy.php

Applicable to:

  • Plesk 12.5 for Windows

Symptoms

Attempt to update to Joomla 3.4.8-89 failed with the following error:

Updating an installation of Joomla 3.4.8-89 has failed: ◦Non-zero exit status returned by script. Output stream: 'PHP Warning: require_once(C:\\Inetpub\\vhosts\\domain.tld\\libraries/import.legacy.php): failed to open stream: No such file or directory in C:\\Program Files (x86)\\Parallels\\Plesk\\var\\apspackages\\aps6A3E.tmp.zipb5eedac8-c1c8-ac97-fd\\cache\\scripts\\bootstrap-administrator.php on line 19 ◦PHP Fatal error: require_once(): Failed opening required 'C:\\Inetpub\\vhosts\\domain.tld\\libraries/import.legacy.php' (include_path='.;.\\includes;.\\pear') in C:\\Program Files (x86)\\Parallels\\Plesk\\var\\apspackages\\aps6A3E.tmp.zipb5eedac8-c1c8-ac97-fd\\cache\\scripts\\bootstrap-administrator.php on line 19

Cause

This is Joomla package issue with ID #APSI-569 , which is planned to be fixed in the next package versions.

Resolution

  • Edit mentioned in the error message bootstrap-administrator.php file

  • Replace

    $adm = getenv('WEB___DIR') . '/administrator';

    with

    $adm = getenv('WEB___DIR') . DIRECTORY_SEPARATOR . 'administrator';
Have more questions? Submit a request
Please sign in to leave a comment.