"451 4.7.1 Service Unavailable - Try Again Later" Messages in the Maillog

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 10.4 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:18:15 UTC

Modified:

2017-02-20 22:28:09 UTC

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"451 4.7.1 Service Unavailable - Try Again Later" Messages in the Maillog

Symptoms

The following error can be observed in the /usr/local/psa/var/log/maillog :

postfix/smtpd[31266]: connect from unknown[unknown]
/usr/lib64/plesk-9.0/psa-pc-remote[1489]: Unable to interpret remote host address
postfix/smtpd[31266]: NOQUEUE: milter-reject: CONNECT from unknown[unknown]: 451 4.7.1 Service
unavailable - try again later; proto=SMTP
postfix/smtpd[31266]: lost connection after CONNECT from unknown[unknown]
postfix/smtpd[31266]: disconnect from unknown[unknown]

Do I need to do anything about them?

Cause

The above messages may appear as a result of the following scenario:

  1. A connection is established on the TCP level;
  2. Postfix receives the signal on this and starts to process the request;
  3. There are many operations that must be completed before Postfix gets the details of the network connection, and the connection is closed while Postfix tries to get socket details;
  4. Since the system has closed the connection, at the point when the data is gathered, the "unknown" IP address is determined and logged.

In general, such a scenario might occur if the following is true:

  1. The remote (or intermediate) host closes the connection right after establishing it (port probe or port scan)or
  2. The local system experiences a high load or resource shortage in a network stack.

The first situation is usually very hard to troubleshoot and is purely a system administrator's task.

The second situation is worth looking into because it probably will affect all network services on the server.

In any case, if an SMTP session cannot be established, then the message is deferred and another attempt to deliver this message is scheduled. Sooner or later, the message should be delivered.

Resolution

Check system resource availability and make sure the server is not overloaded.

Note : This is a pure system administrator task and cannot be a reason for a technical support request.

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