Applicable to:
- Plesk for Linux
Symptoms
-
Multi-Factor Authentication is turned on for a customer in Plesk and cannot authenticate as the phone is lost.
-
Under the administrator account, Multi-Factor Authentication is turned off in Google Authenticator for the domain: Plesk > Google Authenticator > Enable Multi-Factor Authentication option is not checked.
Cause
This is Plesk internal issue with ID #PPPM-4485, the fix is considered to be included in the future Plesk updates.
Resolution
-
Connect to the server via SSH. If the root access is not possible, contact the server administrator to perform these actions.
-
Create a Plesk database backup and access the Plesk database:
# plesk db dump psa > /root/psa_dump.sql
# plesk db
-
Determine Plesk client ID for the domain:
MYSQL_LIN: SELECT cl_id FROM domains WHERE name="example.com";
+-------+
| cl_id |
+-------+
| 23 |
+-------+Replace
example.com
with the domain name in question. -
Using
cl_id
from previous query execute the following:MYSQL_LIN: SELECT * FROM ModuleSettings WHERE name="enabled-23";
+-----------+------------+-------+
| module_id | name | value |
+-----------+------------+-------+
| 9 | enabled-23 | true |
+-----------+------------+-------+ -
Verify if
module_id
belongs to Google Authenticator:MYSQL_LIN: SELECT name FROM Modules WHERE id = 9;
+----------------------+
| name |
+----------------------+
| google-authenticator |
+----------------------+ -
Remove records about Google Authenticator for the issued customer:
MYSQL_LIN: DELETE FROM ModuleSettings WHERE name="enabled-23";
MYSQL_LIN: DELETE FROM ModuleSettings WHERE name="secret-23";
Comments
2 comments
followed every step & tried to login using the wp-admin; it is still asking about the 2FA!
I have disabled the Wordfence plugin, logged in to the dashboard & re-activate the plugin again with a new 2FA configuration.
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