Unable to install extension: Corrupted meta.xml file

Created:

2016-11-16 13:17:33 UTC

Modified:

2017-08-08 13:12:19 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Unable to install extension: Corrupted meta.xml file

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

On Ubuntu 14 with Plesk 12.5

  • The following error can be found when trying to install any extension:

    Failed to install the extension: Corrupted meta.xml file.
  • From time to time extension can be installed.

  • In /var/log/plesk/panel.log the following can be found:

    PHP Warning: ZipArchive::extractTo(/opt/psa/tmp/moduleTH70yq/.): failed to open stream: Is a directory; File: /opt/psa/admin/plib/Package.php, Line: 57
    ...
    ERR [panel] Failed to install the extension: Corrupted meta.xml file.
  • Server CPU Model:

    CentaurHauls VIA Nano processor U2250

Cause

Unexpected behavior of sw-engine on a specific CPU. This is Plesk internal issue with ID #PPPM-4278 that was fixed in Plesk Onyx.

Resolution

Upgrade to the latest Plesk version .

Have more questions? Submit a request
Please sign in to leave a comment.