[How to] Backup is shown as invalid in Plesk interface. How to verify it?

Created:

2016-11-16 13:17:10 UTC

Modified:

2017-04-24 11:16:24 UTC

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[How to] Backup is shown as invalid in Plesk interface. How to verify it?

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 10.4 for Linux
  • Plesk 11.0 for Windows
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Windows
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows
  • Plesk 9.5.4 for Linux

Symptoms

Backup from another Plesk server has been uploaded on the new server. A new backup is shown on the Tools & Settings > Backup Manager page. However, it is marked with a red circle and the following pop-up is shown when hovering the mouse pointer over the circle:

This is not a valid backup. Data cannot be restored from this file.

Cause

The backup contains invalid records that do not follow the requirements of the current Plesk version. It is required to validate the backup according to the current Plesk schema and remove or replace any incorrect records.

Resolution

If, for example, the name of the invalid backup is 0902260453 , you may see files like backup_info_0902260453 and converted_info_0902260453 on the Tools & Settings > Backup Manager page in Plesk.

You can validate the backup using the schema " /usr/local/psa/PMM/plesk.xsd ". The file is included in the " psa-migration-manager " package. Verify that it is installed.

  1. In the backup directory, find all <info>.xml backup metadata files that contain 0902260453.

    ~# find /var/lib/psa/dumps/ -name '*info_0902260453.xml'
    /var/lib/psa/dumps/domains/domain1.tld/backup_domain.tld_info_0902260453.xml
    /var/lib/psa/dumps/clients/client3/domains/domain2.tld/backup_domain2.tld_info_0902260453.xml
    /var/lib/psa/dumps/clients/client3/backup_client3_info_0902260453.xml
    /var/lib/psa/dumps/backup_info_0902260453.xml
    /var/lib/psa/dumps/resellers/reseller/backup_reseller_info_0902260453.xml
    /var/lib/psa/dumps/resellers/reseller1/clients/client2/backup_client2_info_0902260453.xml
    /var/lib/psa/dumps/resellers/reseller1/clients/client2/domains/domain3.tld/backup_domain1.tld_info_0902260453.xml
    /var/lib/psa/dumps/resellers/reseller1/backup_reseller1_info_0902260453.xml
    ~#
  2. Verify the backup files first:

    # cd /var/lib/psa/dumps
    # /usr/local/psa/admin/sbin/backup_sign verify backup_info_0902260453.xml > backup_info_0902260453-verified.xml
  3. Format them for convenience:

    # xmllint --format backup_info_0902260453-verified.xml > backup_info_0902260453-formatted.xml

    After this command the XML files will be formatted in a user-friendly way which will make working with them much easier.

  4. Finally, use the xmllint utility to validate them. For example:

    ~# cd /usr/bin
    ~# /usr/bin/xmllint --noout --schema /usr/local/psa/PMM/plesk.xsd backup_info_0902260453-formatted.xml
  5. Correct the misconfiguration in any invalid XML files and delete the status cache file status_WRONG-FORMAT from the directory .discovered. If the status file is missing, it will be regenerated when you open the Tools & Settings > Backup Manager page.

    After all invalid XML files have been corrected and the status file status_WRONG-FORMAT is removed, the backup should be shown as valid on Tools & Settings > Backup Manager .

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