IP address of a domain is changed after the subscription owner was changed

Created:

2016-11-16 13:16:49 UTC

Modified:

2017-08-16 17:10:47 UTC

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IP address of a domain is changed after the subscription owner was changed

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

Domain IP is changed after moving a subscription from the generic user to the default "admin" user. The following command is used:

   # plesk bin subscription --change-owner example.com -owner admin

The IP address assigned to the subscription is not shared between previous and new owner.

The following entries can be found in Plesk action log:

    127.0.0.1 admin [2016-03-07 13:41:15] 'Update Physical Hosting' ('Domain Name': 'example.com' => 'example.com', 'IP Address': '203.0.113.2' => '203.0.113.3')
127.0.0.1 admin [2016-03-07 13:41:20] 'Change Domain Owner' ('Domain Name': 'example.com' => 'example.com', 'Login Name': 'sajarvis' => 'admin')
127.0.0.1 admin [2016-03-07 13:41:20] 'Update Domain DNS Zone' ('Domain Name': 'example.com' => 'example.com')

Cause

This is a software issue with internal ID #PPPM-4251 . It will be fixed in future product updates.

Workaround

Use -map_ip option for the subscription utility to specify the correct IP address, as in an example below:

    # plesk bin subscription --change-owner example.com -owner admin -map_ip <IP_address>

It is described in Plesk documentation .

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