Unable to activate/update/download rules from Atomic Professional ModSecurity ruleset

Created:

2016-11-16 13:16:02 UTC

Modified:

2017-08-08 13:25:09 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to activate/update/download rules from Atomic Professional ModSecurity ruleset

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Symptoms

Unable to activate/update/download rules from Atomic Professional ModSecurity ruleset.

On Linux:
The following error can be found in /var/log/plesk/panel.log with enabled debug :

ERR [util_exec] proc_close() failed ['/usr/local/psa/admin/bin/modsecurity_ctl' '--install' '--with-backup' '--ruleset' 'tortix'] with exit code [1]

Unable to download tortix rule set

ERR [1] PleskUtilException: '/usr/local/psa/admin/bin/modsecurity_ctl' '--install' '--with-backup' '--ruleset' 'tortix' failed with code 1.

Manual execution leads to the following:

# aum -u

...
Errors were encountered:

L CODE SOURCE MESSAGE
- ---- ----------------------------- ------------------------------------------
2 9998 Core::_get_license_key Invalid key data
2 9998 Core::_get_license_key Invalid key data

Also Apache service is down.

On Windows:

The following error appears during activation of rule set:

Error: Failed to update the ModSecurity rule set modsecuritymng failed: Error sending request 'channels/rules/subscription/VERSION' to 'uptdates.atomicorp.com': status 401

Resolution

  1. Open Plesk > Tools & Settings > License Management > Additional License Keys

  2. Open key for Atomic ModSecurity and click Retrieve Additional Key button.

  3. Go to Plesk > Tools & Settings > Web Application Firewall > Atomic Professional ModSecurity > Apply .

Have more questions? Submit a request
Please sign in to leave a comment.