Unable to set Smartermail as default mail server: Unable to assign port to IP address

Created:

2016-11-16 13:15:47 UTC

Modified:

2017-03-05 16:42:57 UTC

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Unable to set Smartermail as default mail server: Unable to assign port to IP address

Symptoms

Unable to set SmarterMail as default mail server due to an error:

Error: Unable to set SmarterMail Server XX.XX as the default Mail Server: defpackagemng failed: Unable to assign port to IP address.
Reason:
Unknown IP Address:
(Error code 1)

Cause

MailEnable was not properly stopped.

Resolution

  1. Stop all services of MailEnable and try switching to SmarterMail again.

  2. If the step above did not help, do the following:

    2.1 In regedit in Local_Machine > Software > Wow6432Node > Plesk > PSA Config > Config set MAIL_PROVIDERW_DLL parameter with path to Plesk smartermailprovider.dll library, e.g. "C:\Program Files (x86)\Parallels\Plesk\admin\bin\smartermailprovider.dll"

    2.2. In Local_Machine > Software > Wow6432Node > Plesk > PSA Config > Config > Packages > Mailserver set Default to smartermail

    2.3. In Plesk Home > Tools & Settings > Server Components click Refresh button

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