Applicable to:
- Plesk Onyx for Linux
- Plesk Onyx for Windows
Symptoms
Unable to manage the Security settings available at Hosting Settings in Plesk Onyx:
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SSL/TLS Support
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Permanent SEO-safe 301 redirect from HTTP to HTTPS
Cause
The permission Hosting settings management is disabled in the respective Service Plan.
Resolution
In Plesk Onyx it's required to enable Hosting settings management permission to manage SSL/TLS Support and Permanent SEO-safe 301 redirect from HTTP to HTTPS:
Click on a section to expand
-
Depending on the subscription status:
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Subscription is synchronized: Service Plans > Service Plan Name > Permissions > Enable Hosting settings management option > Click Update & Sync
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Subscription is locked/customized: Subscriptions > example.com > Customize > Permissions > Enable Hosting settings management option > Click Update & Lock
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Go to Tools & Settings > Custom View Settings > Hosting Tools > Enable Hosting settings management option > Click OK to save the changes
Comments
7 comments
Hallo,
Ich sitze seit Zwei Tagen! SSL Zertifikat instaliert - nichts funktioniert! Ich kann nichts auswählen bei Hosting-Optionen und Berechtigungen.
Hello @Marie,
Could you please log in the server using SSH/ RDP and provide the output of the following command:
------------
plesk bin subscription_settings --info example.com | grep "manage_phosting"
------------
In case you don't have access to the server, most possible the corresponding permission "Hosting settings management " is disabled by Plesk admin.
In this case, please contact Plesk administrator and ask to grant this permission.
The following article might be helpful https://support.plesk.com/hc/en-us/articles/115002388985
Hello
It's is not working in Plesk Obsidian on Linux for sure. we executed the command on one subscription where the subscription has the right to change it but it can not be changed at all:
plesk bin subscription_settings --info xyz.ch | grep "manage_phosting"
manage_phosting true Hosting settings management
Hello Chris Mayer,
I've checked the described behavior on a test server:
plesk -v
Product version: Plesk Obsidian 18.0.20
OS version: CentOS 7.5.1804 x86_64
Build date: 2019/10/29 11:00
I've created a customer and a subscription for this customer.
I've logged into Plesk as this customer and saw that option for "Permanent SE)-safe 301 redirect from HTTP to HTTPS" wasn't active.
After that, I've logged into Plesk as admin, and followed the instruction from this article.
After the above manipulation, I was able to enable the required option as the customer.
Please, check it once again and submit a support request in case the issue persists for you.
Hello Ivan
Thanks for the test. we tested it again and as customer we have no change at all to enable or disable the SSL/TLS support nor teh 301 redirect.
at your test where you able as customer after manage_hosting set to true to enable and disable the options? or only a admin?
our installation is an upgraded plesk obsidian from onyx:
Product version: Plesk Obsidian 18.0.20.2
OS version: CentOS 7.7.1908 x86_64
Build date: 2019/11/01 13:00
Hello @Simple Hosting GmbH,
> at your test where you able as a customer after manage_hosting set to true to enable and disable the options? or only a admin?
On my test server after applying the steps from "Resolution" I was able to change this setting as a customer too:

If the issue is still actual for you, feel free to submit a support request because investigation on the server is required.
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