On October 19, 2021, we have enabled single-sign-on for our Plesk Support Center to provide a seamless login/account experience. This implies that you’ll be able to use a single account across any of our web-facing properties.
If you had already registered your account at Plesk 360 (formerly known as My Plesk) please use one for login. Otherwise please re-register it using the same email address as your existing Zendesk login (support account). It’s essential that you use the same email address on our support center to ensure that your tickets stay attached to the same account.

Webmail is not working on Plesk server: Error when communicating with the server

Follow

Comments

10 comments

  • Avatar
    Gerasimos Perentidis

    I have the same issue with plesk 17.8.11.

    I have the Comodo rules. I added the custom settings but it did not solve the issue.

    Only when I DE-activated the CWAF rule/tag, was I able to send messages via webmail.

    1
    Comment actions Permalink
  • Avatar
    Nikita Nikushkin

    Hi @Gerasimos Perentidis!

    Indeed, the provided resolution was for the OWASP ModSecurity rule set, while you found for the Comodo one. Thus, the solution differs

    I added your information to the article in order to make it helpful for users who have the Comodo ModSecurity rule set

    Thank you!

    0
    Comment actions Permalink
  • Avatar
    Antrax1

    Hi,

    I have this problem only in IMAP email accounts and OWASP rules,  try this solutions but don´t work.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Antrax1,

    You seem to have another issue.

    Submit a request to Plesk Support, as a deeper investigation is required, here's the instruction: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-

    0
    Comment actions Permalink
  • Avatar
    Miguel Ángel

    Hi!!

    I can not disable rules for Roundcube :(

    What's wrong in this configuration:

    <Directory /usr/share/psa-roundcube>
    <IfModule mod_security2.c>
    SecRuleRemoveById 212880
    </IfModule>
    </Directory>

    Thank you!!

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello Miguel Ángel

    Do I get it right that you want to disable a ModSecurity rule?

    Please, check the "Server-wide" section in this instruction: https://support.plesk.com/hc/en-us/articles/115002531753

    0
    Comment actions Permalink
  • Avatar
    Bernardo (Edited )

    I'm using Roundcube with Comodo and the above suggestion to add "SecRuleEngine Off" to custom directives did NOT work for me.  I ended up fixing my issue by adding ID 212880 to the "Switch off security rules" list in Plesk.

     
     
    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Bernardo

    Thank you for sharing your user experience. 

    0
    Comment actions Permalink
  • Avatar
    Gonçalo Matos

    I'm using Roubcube 1.4.11 with Plesk 18.0.34 and Comodo running on Apache (ModSecurity 2.9) and was having the same problem. The suggested solution (add ID 212880 to the Security rule IDs text box) did not work. However, I've tried the one suggested in the comments by Gerasimos Perentidis and deactivated the the CWAF rule/tag. The problem was solved. Is it bad to have this security rule deactivated? Can you suggest me another solution if so?

    0
    Comment actions Permalink
  • Avatar
    Carlo Panceri

    I use resolution for Roundcube and  OWASP ModSecurity ruleset but doesn't work. When apply rule on Custom Directives i receive this error:

    File: /etc/nginx/modsecurity.d/plesk.custom.conf. Line: 1. Column: 30. Invalid input: <LocationMatch "/roundcube/"> in /etc/nginx/conf.d/modsecurity.conf:6 nginx: configuration file /etc/nginx/nginx.conf test failed

    How can i resolve?

    Thanks

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request