Plesk update fails with warning: MySQL server is running with the --skip-grant-tables option

Refers to:

  • Plesk for Windows
  • Plesk 11.0 for Linux

Created:

2016-11-16 13:14:25 UTC

Modified:

2016-12-21 20:15:52 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk update fails with warning: MySQL server is running with the --skip-grant-tables option

Symptoms

Plesk upgrade fails with error:

    /var/lib/psa/dumps/mysql.preupgrade.9.5.4-11.0.9.20130802-164801.dump.gz
ERROR 1290 (HY000) at line 1: The MySQL server is running with the --skip-grant-tables option so it cannot execute this statement

Cause

Option skip-grant-tables is enabled in /etc/my.cnf .

Resolution

  1. Disable option skip-grant-tables in /etc/my.cnf as below:

    for RedHat-based OS

    # vi /etc/my.cnf
    [mysqld]
    #skip-grant-tables

    for Debian-based OS

    # vi /etc/mysql/my.cnf
    [mysqld]
    #skip-grant-table
  2. Restart MySQL server:

    for RedHat-based OS

    # /etc/init.d/mysqld restart

    for Debian-based OS

    # /etc/init.d/mysql restart
  3. Check MySQL server connectivity:

    MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa
  4. Start the upgrade again

Have more questions? Submit a request
Please sign in to leave a comment.