Applicable to:
- Plesk 11.x for Linux
Symptoms
When setting catch-all email address in mail settings under Home > Subscriptions > SUBSCRIPTION > Mail tab > Change Settings , it does not work for secondary domains.
The following error appears in
maillog
:
<nonexistent@domain.tld>: Recipient address rejected: User unknown in virtual mailbox table
Cause
This settings is applied not for all domain in the subscription. Such behavior is considered to be a software issue #PPPM-816 .
Resolution
According to Plesk 12 Release Notes mail settings have been redesigned and "Mail sent to non-existent users" feature can be configured for individual domains. Please consider upgrading your Plesk to the latest version.
As a workaround use the following command to add catch-all email address to domain:
# /usr/local/psa/bin/domain_pref -u domain.tld -no_usr mail@domain.tld
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