Could not create user: "Specified column "localeId" is not in the row"

Created:

2016-11-16 13:13:55 UTC

Modified:

2017-04-24 11:23:59 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Could not create user: "Specified column "localeId" is not in the row"

Applicable to:

  • Plesk 11.5 for Windows
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

When I try to create an user, I get the following error:

Message Specified column "localeId" is not in the rowFile     Abstract.phpLine    179Type    Zend_Db_Table_Row_Exception

Cause

Not all Parallels Plesk Panel (Plesk) packages were successfully upgraded.

Resolution

You should reinstall the plesk-core package and install all the microupdates:

  1. Backup the current psa database:

    mysqldump -uadmin -p`cat /etc/psa/.psa.shadow ` psa > ~/psa_kb117977.`date +%F`
  2. Remove the broken plesk-core package:

    rpm -e --nodeps --justdb --noscripts plesk-core

    NOTE:

    --nodeps                         do not verify package dependencies--justdb                         update the database, but do not modify the--noscripts                      do not execute package scriptlet(s)
  3. Download the plesk-core package for your OS version. For example, for CentOS 6, x86_64:

    wget http://autoinstall.plesk.com/PSA_11.5.30/dist-rpm-CentOS-6-x86_64/base/plesk-core-11.5.30-cos6.build115130819.13.x86_64.rpm
  4. Install the downloaded package:

    rpm -ivh plesk-core-11.5.30-cos6.build115130819.13.x86_64.rpm
  5. Install all microupdates:

    /usr/local/psa/admin/bin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base
Have more questions? Submit a request
Please sign in to leave a comment.