Cannot open Sitebuilder 4.5 site in Wizard: "To access Parallels Presence Builder REST API you need correct login and password"

Refers to:

  • Plesk Sitebuilder 4.5 for Linux

Created:

2016-11-16 13:13:49 UTC

Modified:

2016-12-21 20:14:29 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot open Sitebuilder 4.5 site in Wizard: "To access Parallels Presence Builder REST API you need correct login and password"

Symptoms

The following error appears when I try to open Sitebuilder 4.5 Wizard under client account:

To access Parallels Presence Builder REST API you need correct login and password

The same error is shown when I open Sitebuilder Wizard through http://%sitebuilder4.5_node%/Wizard .

Cause

This Sitebuilder 4.5 node is in the migrating process. The following URL for Parallels Web Presence Builder node is configured:

/usr/local/sitebuilder/config
---8<---
[migrator]
wpb_url = "https://%wpb_node%/"
wpb_password = "Hy{yZ#\\]CLf!y7Y}K9&'m2IR@hOj,qZY(r!e!Mq(d4nh'MUB.Rb?MbRu_P:"
--->8---

Error " To access Parallels Presence Builder REST API you need correct login and password " appears when try to open WPB URL https://%wpb_node%/api/5.3/sites/ (used by Parallels Plesk Sitebuilder 4.5).

Resolution

Make sure that " wpb_password " from /usr/local/sitebuilder/config is correct and matches WPB for PA password that can be found in POA. Refer to this KB for more detail.

Additional information

Migrating from Parallels SiteBuilder 4.5 Standalone Installations to Parallels Presence Builder 11.5

Have more questions? Submit a request
Please sign in to leave a comment.