Plesk upgrade failed with error: The following packages have unmet dependencies

Created:

2016-11-16 13:13:31 UTC

Modified:

2017-04-24 11:42:31 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade failed with error: The following packages have unmet dependencies

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 12.0 for Linux

Symptoms

  • Plesk upgrade failed with following error on Ubuntu 12.04:

    The following packages have unmet dependencies
    plesk-core : Depends: libapache2-mod-perl2 but it is not going to be installed
    Depends: libapache2-mod-python but it is not going to be installed
  • Unable to reconfigure webspace:

    apache2: Syntax error on line 140 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/fcgid.load: Cannot load /usr/lib/apache2/modules/mod_fcgid.so into server: /usr/lib/apache2/modules/mod_fcgid.so: undefined symbol: unixd_config
    • Apache 2.4 version is installed on the server:

      httpd -v

      Server version: Apache/2.4 (Unix)

Cause

During upgrade, Plesk needs to install Apache from official repositories, but packages conflict with Apache 2.4.

Resolution

Downgrade apache to 2.2 or uninstall it and rerun plesk upgrade.

Ubuntu 12.04 and older supports Apache 2.2 version.

Have more questions? Submit a request
Please sign in to leave a comment.