Migration fails with error: Element 'certificates': This element is not expected

Created:

2016-11-16 13:12:50 UTC

Modified:

2017-04-24 11:42:52 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Migration fails with error: Element 'certificates': This element is not expected

Applicable to:

  • Plesk for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 10.0.0 for Linux

Symptoms

Migration from old Plesk server to Plesk 10/11.0 or to Plesk 12 fails with error:

Warning: 
Deployer has been terminated by exception:
Line 296 error: Element 'certificates': This element is not expected. Expected is one of ( sb-config, backup-settings, server-preferences, spamassassin, grey-listing, virusfilter, kav-settings, coldfusion, gapps-services, events ).

or migration dump is invalid:

xmllint --format --noout --schema /usr/local/psa/PMM/restore-specification.xsd /usr/local/psa/PMM/rsessions/20130512160658912/restore.xml

/usr/local/psa/PMM/rsessions/20130512160658912/restore.xml:2471: element properties: Schemas validity error : Element 'properties': This element is not expected. Expected is one of ( sb-config, backup-settings, server-preferences, spamassassin, grey-listing, virusfilter, kav-settings, coldfusion, gapps-services, events ).

/usr/local/psa/PMM/rsessions/20130512160658912/restore.xml fails to validate

Cause

Internal software issue #PPPM-617 it was fixed in Plesk 11.5.
For Plesk 12 it will be fixed in one of the future product updates.

Resolution

If your Plesk version is below 11.5 consider to upgrade to Plesk 11.5 .

Workaround:

  1. Remove SSL certificates from source server (or disable them under migrating subscriptions).

  2. Perform migration.

  3. Install SSL certificates on destination server.

Have more questions? Submit a request
Please sign in to leave a comment.