Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Unable to register Apache Tomcat:
-
Apache Tomcat is installed and is shown as running in Plesk at Tools & Settings > Service Management.
OR
Apache Tomcat is installed but cannot be started at Tools & Settings > Service Management: A floating notification says "Service is not configured" and management buttons are grayed out:
-
There is no Java applications menu at Domains > example.com.
-
Java applications is shown as Off at Tools & Settings > License Management.
-
Unable to register PostgreSQL or Microsoft SQL Server:
-
PostgreSQL / MS SQL Server is not available in Plesk at Tools & Settings > Database Servers.
-
The PostgreSQL / MS SQL Server function icons are grayed-out at Tools & Settings > Service Management:
-
PostgreSQL database server support / Microsoft SQL Server support is shown as Off at Tools & Settings > License Management.
Cause
The installed Plesk license (e.g. Web Admin) does not have the Power Pack / Developer Pack add-on which includes management modules for PostgreSQL and Microsoft SQL Server.
Resolution
Purchase the Power Pack or Developer Pack add-on in Plesk Store. For assistance, contact Plesk Online Sales team.
Alternatively, consider upgrading your license to Web Pro or Web Host (they have PostgreSQL/MSSQL management by default).
Note: After purchasing the Power Pack add-on or upgrading the license, activate it in Plesk by going to Tools & Settings > License Management and clicking Retrieve Keys.
Comments
0 comments
Please sign in to leave a comment.