Plesk Reconfigurator sets "Deny" permissions on Plesk folders

Created:

2016-11-16 13:12:39 UTC

Modified:

2017-04-24 11:43:01 UTC

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Plesk Reconfigurator sets "Deny" permissions on Plesk folders

Applicable to:

  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

  1. When run Plesk Reconfigurator > Repair Plesk Installation > Plesk File Security it sets Deny permissions on %plesk_dir% and its sub-folders for all Plesk users.
    As a result Plesk and all websites are down.

  2. In registry HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\PLESK\\PSA Config\\Config value of PRODUCT_ROOT_D is set as C:\\PROGRA~2\\Parallels\\Plesk .

Cause

Bug #PPPM-3331 . It is fixed in Plesk Onyx.

Resolution

Upgrade to the latest Plesk version .

If upgrade is not possible:

  1. Backup registry branch HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\PLESK\\PSA Config\\Config .

  2. Set value PRODUCT_ROOT_D as C:\\Program Files (x86)\\Parallels\\Plesk .

  3. Restart Plesk Management service.

  4. Run Plesk Reconfigurator utility to restore correct permissions.

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