SMTP Server status is shown as stopped in Plesk CP and messages are sent from the mail client with a delay

Created:

2016-11-16 13:12:30 UTC

Modified:

2017-04-24 11:30:22 UTC

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SMTP Server status is shown as stopped in Plesk CP and messages are sent from the mail client with a delay

Applicable to:

  • Plesk for Linux
  • Plesk 12.0 for Linux

Symptoms

SMTP Server (Qmail) is shown with the status Inactive on Services Management page in Plesk. QMail service is available and emails are delivered with delay.

Cause

SMTP does not return an immediate answer as it is required by the status checker. Use the following command to verify the response time:

[root@host ~]# time telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
quit
220 your.plesk.server.hostname ESMTP
221 your.plesk.server.hostname
Connection closed by foreign host.
real    2m31.285s
user    0m0.002s
sys     0m0.001s
[root@host ~]#

Such a huge delay may be caused by DNSBL servers configured in your Plesk:

Home > Mail Server Settings > Switch on spam protection based on DNS blackhole lists :

 address1;address2;address3;address4;address5;address6

Resolution

Make sure that all RBL Servers respond fast and that they are resolved from the Plesk server. If some of them do not work as expected, remove it.

Additional Information

SMTP Service status may also be shown as stopped if port 25 is closed for local connections by a firewall. Verify that the port is opened:

 # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 your.plesk.server.hostname ESMTP

If you see the following output, the port is closed, and you need to reconfigure the firewall to open the port:

 # telnet localhost 25
Trying 127.0.0.1...
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