Cannot connect to KA Demo

Created:

2016-11-16 13:12:13 UTC

Modified:

2017-04-24 11:43:14 UTC

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Cannot connect to KA Demo

Applicable to:

  • Web Presence Builder
  • Plesk
  • Plesk Sitebuilder

Symptoms

It is not possible to connect to KA Demo server. The following errors may occur:

Licensing Server Unreachable: Unable to connect with licensing server.
Please make sure that your network allows communication to ka.demo.plesk.com:5224.
For more details check system help pages.

or

Couldn't resolve host name

or

Can't connect to ka.demo.plesk.com:5224 (Timeout)

Cause

The Plesk product tries to connect to the KA Demo server ka.demo.plesk.com at port 5224 to update the license, but it cannot establish a connection.

Resolution

On December 1, 2014 , the IP address of the KA Demo server will be changed to 195.214.233.70 (IPv4) and 2001:67c:730::46 (IPv6). Make sure that the hostname ka.demo.plesk.com resolves to the proper IP from your server:

# nslookup ka.demo.plesk.com

If the KA Demo server does not resolve to the correct IP, check the /etc/hosts file.

If any of these servers are behind a firewall and old IP addresses of KA Demo server are listed in the firewall rules, please add new IP addresses of KA Demo server to the firewall rules before December 1st . This is to allow your servers to connect to ka.demo.plesk.com after it will start resolving to new IP addresses. This can be checked with these commands:

# nmap -P0 -p5224 ka.demo.plesk.com
# telnet ka.demo.plesk.com 5224
# traceroute ka.demo.pelsk.com

If you are using the APF firewall, check /etc/apf/allow_hosts.rules for the mentioned IPs or the hostname ka.demo.plesk.com .

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