Plesk upgrade to version 12 fails with error: 'CentOS' 'Linux' '6.4' 'x86_64'" is not supported

Refers to:

  • Plesk for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:11:22 UTC

Modified:

2016-12-21 20:09:00 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade to version 12 fails with error: 'CentOS' 'Linux' '6.4' 'x86_64'" is not supported

Symptoms

Plesk upgrade to version 12 fails with error:

    Exception: Failed to solve dependencies:
psa-mod_fcgid-2.3.9-14033111.x86_64 requires httpd
psa-phppgadmin-5.1-cos6.build1200140423.17.noarch requires httpd
psa-mailman-configurator-12.0.18-cos6.build1200140606.15.x86_64 requires mailman >= 2.1
pp12.0.18-bootstrapper-12.0.18-cos6.build1200140626.18.x86_64 requires mysql-server >= 5.0.60
plesk-core-12.0.18-cos6.build1200140606.15.x86_64 requires mysql-server >= 5.0.60
plesk-web-hosting-12.0.18-cos6.build1200140606.15.x86_64 requires mod_ssl
psa-mod_sysenv-0.1-14033112.x86_64 requires httpd
psa-php5-configurator-1.6.3-cos6.build1200140526.11.x86_64 requires php
psa-spamassassin-12.0.18-cos6.build1200140606.15.x86_64 requires spamassassin >= 3.0.0
plesk-core-12.0.18-cos6.build1200140606.15.x86_64 requires openssh-clients
3:psa-qmail-1.03-cos6.build1200140526.11.x86_64 requires inetd
psa-php5-configurator-1.6.3-cos6.build1200140526.11.x86_64 requires httpd
psa-proftpd-1.3.5-cos6.build1200140529.18.x86_64 requires xinetd
psa-mod_rpaf-0.6-14033112.x86_64 requires httpd
plesk-core-12.0.18-cos6.build1200140606.15.x86_64 requires vixie-cron
plesk-core-12.0.18-cos6.build1200140606.15.x86_64 requires ntp
psa-phpmyadmin-4.2.5-cos6.build1200140702.16.noarch requires httpd
plesk-web-hosting-12.0.18-cos6.build1200140606.15.x86_64 requires httpd
awstats-7.3-14050621.parallels.noarch requires httpd
psa-mod_aclr2-14033111-9e86c2f.x86_64 requires httpd

ERROR: The Yum utility failed to install the required packages.

Also error may be like this:

    Installation will not continue because your operating system
"'CentOS' 'Linux' '6.4' 'x86_64'" is not supported.

Cause

Third-party mirror is enabled in base repository.

Resolution

  1. Make sure that there is no file /root/.autoinstallerrc with third-party mirror, because Plesk will try to download packages from this repostory first.

  2. Make sure that, there is no third-party mirror in /etc/yum.repos.d/CentOS-Base.repo. Example:

    # cat /etc/yum.repos.d/CentOS-Base.repo
    [base]
    name=CentOS-$releasever - Base
    mirrorlist=http://s2plmirror01.prod.sdl2.secureserver.net/download/mirrors/cos-$releasever.$basearh
    failovermethod=priority
    baseurl=http://mirror.centos.org/centos/$releasever/os/$basearch/
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-6
  3. Disable this mirror and launch Plesk upgrade once again.

Have more questions? Submit a request
Please sign in to leave a comment.