Cannot log in to CP for managing Plesk: "Cannot log you in to Parallels Panel with your saved password"

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 13:11:17 UTC

Modified:

2016-12-21 20:08:47 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot log in to CP for managing Plesk: "Cannot log you in to Parallels Panel with your saved password"

Symptoms

After upgrading Plesk from 10.4.4 to 11.x, the provider or client cannot log in to CP. The following error appears:

Cannot log you in to Parallels Panel with your saved password. Click here to reset the password.

If he tries to update the password, he gets another error:

An error occurred during a Plesk operation

The following error may be shown in the GUI and in the Plesk log ( /var/log/sw-cp-server/error_log ):

2013-08-01 14:29:17: (mod_fastcgi.c.2746) FastCGI-stderr: PHP Fatal error:  Call to a member function setLocale() on a non-object in /usr/local/psa/admin/htdocs/enterprise/rsession_init.php on line 34

Cause

  1. The issue initially appeared in OBAS 4.2 and Plesk 11.0.9. The OBAS bug PBAS-27906 has been fixed since version 4.2.1; the Plesk bug #112129 has been fixed since version 11.5.
  2. Applications from the subscription's plan are not installed on the Plesk node.

Resolution

  1. Ensure that your OBAS version is newer than 4.2.1 and that your version of Plesk is newer than 11.5. If you have an older version, then you should upgrade. Please refer to these documents for upgrade instructions:

    How to upgrade OBAS system to the latest available version

    Upgrading Plesk to 11.5

  2. Follow these steps:

    • Try to reset the password from the Customer Panel.

    • Check the OBAS log ( Top > Configuration Director > Logging and Errors > Action Log ) for the new domain-related failed action and check its problem report. There you will see an error like Error provisioning to Plesk. The following site applications not found on plesk node: <applications list> .

  3. Either install the listed applications on the domain PP node or remove them from the domain's subscription plan and upgrade the subscription to the thus created latest plan version.

    Note that installing applications on the PP node is the preferable way to install the applications if the subscription resides on an older plan version; besides the applications list, other subscription properties can also be changed during an upgrade to the latest plan version.

Additional information

Cannot log in to CP for managing Plesk subscription because of redirect loop

Have more questions? Submit a request
Please sign in to leave a comment.