Unable to connect to SmarterMail: No connection could be made because the target machine actively refused it

Created:

2016-11-16 13:11:12 UTC

Modified:

2017-04-24 11:19:03 UTC

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Unable to connect to SmarterMail: No connection could be made because the target machine actively refused it

Applicable to:

  • Plesk for Windows

Symptoms

SmarterMail webmail shows the  error:

Server Error in '/' Application.
No connection could be made because the target machine actively refused it 127.0.0.1:17001
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
Exception Details: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:17001

Cause

  1. The Mail Server is being restarted and has not fully come back online yet.

  2. Microsoft .NET 4 is broken.

  3. The SmarterMail installation is broken.

Resolution

  1. Restart SmarterMail service.

  2. Apply solution from SmarterMail portal: No connection could be made .

  3. If it did not help, repair Microsoft .NET 4:

    1. Go to Control Panel > Programs and Features
    2. Scroll down to Microsoft .NET 4 Client Profile
    3. Right click, then select Repair
    4. When repair is done, find Microsoft .NET Extended
    5. Right click, then click Repair again
    6. When done repairing, reboot
  4. Repair SmarterMail using the following steps:

    1. Go to Control Panel > Programs and Features
    2. Scroll down to SmarterMail
    3. Right click, and select Repair
    4. When done repairing, reboot
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