Plesk 12.5 System Requirements

Created:

2016-11-16 13:09:46 UTC

Modified:

2017-04-24 11:31:34 UTC

1

Was this article helpful?


Have more questions?

Submit a request

Plesk 12.5 System Requirements

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows
  • Plesk 10.x and below for Windows

Information

Plesk 12.5 System Requirements are listed on the following page:

Plesk documentation, including User's and Admin's Guides is available here:

Have more questions? Submit a request
Please sign in to leave a comment.