Cannot open PhpMyAdmin: Cannot connect: invalid settings

Created:

2016-11-16 13:09:33 UTC

Modified:

2017-08-16 16:17:22 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot open PhpMyAdmin: Cannot connect: invalid settings

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 12.0 for Linux

Symptoms

When try to open PhpMyAdmin for domain database, message Access denied! is shown:

Cannot connect: invalid settings

error.PNG

Cause

Database user password saved in Plesk and set in MySQL server mismatch.

Resolution

It is needed to sync passwords. Reset the password for domain database user:

For Plesk 12 :

Subscriptions > example.com > Website & Domains > Databases > select necessary database > switch to Users tab > open needed user > enter new password:
120.PNG

For Plesk 12.5 and higher :

Subscriptions > example.com > Databases > select the user under the certain database > enter new password:

175.PNG

As an alternative, update database user password from CLI:

  1. Connect to the server using SSH.
  2. Run the following command:
    # /usr/local/psa/bin/database --update-dbuser <user_name> -passwd <new_password> -server localhost:3306
Note : Change <user_name> and <new_password> on the needed ones.
Have more questions? Submit a request
Please sign in to leave a comment.