Cannot configure ASP.NET on domain: "Can't detect .NET version. Possible site does not use ASP.NET"

Refers to:

  • Plesk for Windows
  • MG:97a4f39f4120c161e117ef56f9de1f07
  • MT:1ca59d51adf8cc609d3977e96e1eadf9

Created:

2016-11-16 13:09:16 UTC

Modified:

2017-02-13 06:11:47 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot configure ASP.NET on domain: "Can't detect .NET version. Possible site does not use ASP.NET"

Symptoms

Changing ASP.NET setting for domain is showing the following error in Plesk Panel:

ASPdotNet() constructor failed: Unable to getDomainConfiguration: aspnetcfg failed: Can't detect .NET version. Possible site does not use ASP.NET
---------------------- Debug Info -------------------------------
0: ASPDotNETUIPointer.php:69
ASPDotNETUIPointer->accessItem(string 'GET', NULL null)
1: UIPointer.php:600
UIPointer->access(string 'GET')
2: plesk.php:50

Cause

Missing ASP.NET handler for the domain in IIS configuration.

Resolution

  1. Open IIS Manager ( Start > Run > inetmgr ).

  2. Select problem domain and open "Handler Mappings" .

  3. Press "Revert to parent" .

Have more questions? Submit a request
Please sign in to leave a comment.