Applicable to:
- Plesk for Linux
Symptoms
- Mail accounts with Access to the Control Panel option set in Domains > example.com > Email Addresses > mailbox name cannot log into Plesk GUI with PLAIN password if the password is encrypted in the database. The following error is displayed:
PLESK_ERROR: Error: You have entered incorrect username or password.
- The users had an encrypted password before the upgrade:
# mysql -uadmin -p`cat /etc/psa/.psa.shadow` -Dpsa -e "select mail_name, domains.name as domain from accounts, mail,domains where dom_id = domains.id and mail.account_id = accounts.id and type='crypt'"
+-----------+--------+
| mail_name | domain |
+-----------+--------+
| admin | example.com |
+-----------+--------+ -
PLAIN
authentication to the mail server itself works without issues, only Plesk GUI login does not work.
Cause
Product issues:
- #PPPM-1405 Open
-
#PPP-43681 "While updating to Plesk Obsidian, a misleading error message âWARNING: There are 1 mail accounts with passwords encrypted using a deprecated algorithmâ is no longer shown because the corresponding bug PPP-43681 (about email address accounts, whose passwords were encrypted) has been already fixed."
Fixed in:- Plesk Obsidian General Availability (GA 18.0.20) 22 October 2019 (Linux)
Resolution
Workaround
- Connect to the server via SSH
- Get a list of mail users with encrypted passwords (affected users):
# mysql -uadmin -p`cat /etc/psa/.psa.shadow` -Dpsa -e "select mail_name, domains.name as domain from accounts, mail,domains where dom_id = domains.id and mail.account_id = accounts.id and type='crypt'"
+-----------+--------+
| mail_name | domain |
+-----------+--------+
| admin | example.com |
+-----------+--------+ - Change the password for all users retrieved from the list in Domains > example.com > Email Addresses > mailbox name
As a workaround for Plesk 12.5 and Plesk Onyx, use:
Note: This fix below will resolve the issue for encrypted passwords which starts with "$1$".
Note: For Plesk 12.5 the custom fix can be applied without password changing.
Click on a section to expand
Plesk 12.5 and Plesk Onyx 17.0:
# wget https://support.plesk.com/hc/en-us/article_attachments/360004705833/User_1.zip
# unzip User_1.zip
# mv /usr/local/psa/admin/plib/Smb/Db/Table/Row/User.php{,.bk}
# mv User.php /usr/local/psa/admin/plib/Smb/Db/Table/Row/User.php
Plesk Onyx 17.5:
# wget https://support.plesk.com/hc/en-us/article_attachments/360004678194/User_2.zip
# unzip User_2.zip
# mv /usr/local/psa/admin/plib/Smb/Db/Table/Row/User.php{,.bk}
# mv User.php /usr/local/psa/admin/plib/Smb/Db/Table/Row/User.php
Plesk Onyx 17.8:
# wget https://support.plesk.com/hc/en-us/article_attachments/360004707293/User_3.zip
# unzip User_3.zip
# mv /usr/local/psa/admin/plib/Smb/Db/Table/Row/User.php{,.bk}
# mv User.php /usr/local/psa/admin/plib/Smb/Db/Table/Row/User.php
Plesk 12.5 and Plesk Onyx 17.0:
# wget https://support.plesk.com/hc/en-us/article_attachments/360004707293/User_1.zip
# unzip User_1.zip
# mv /opt/psa/admin/plib/Smb/Db/Table/Row/User.php{,.bk}
# mv User.php /opt/psa/admin/plib/Smb/Db/Table/Row/User.php
Plesk Onyx 17.5:
# wget https://support.plesk.com/hc/en-us/article_attachments/360004707293/User_2.zip
# unzip User_2.zip
# mv /usr/local/psa/admin/plib/Smb/Db/Table/Row/User.php{,.bk}
# mv User.php /usr/local/psa/admin/plib/Smb/Db/Table/Row/User.php
Plesk Onyx 17.8:
# wget https://support.plesk.com/hc/en-us/article_attachments/360004707293/User_3.zip
# unzip User_3.zip
# mv /opt/psa/admin/plib/Smb/Db/Table/Row/User.php{,.bk}
# mv User.php /opt/psa/admin/plib/Smb/Db/Table/Row/User.php
Comments
2 comments
Hi, also similar problem i suppose, when users try to connect to their webmail and receive password is not correct. This happend after updating plesk.
Any solution for this?
Thanks
Hello Rooftop
In this article, only Plesk login isn't possible.
Please, try these articles:
https://support.plesk.com/hc/en-us/articles/213407829
https://support.plesk.com/hc/en-us/articles/115000557474
In case this wouldn't help, submit a request to support.
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